Logo

Welcome to the NCSC Online System Tune-up. This page will help you configure your system for the optimal settings required for your Web courses.

Systems Requirements
Check the list below to see if you have the computer and browser configurations that will give you the best viewing experience.

  • Microsoft Windows 2000, Windows 2003, Windows XP, Windows 7 or Macintosh OS X
  • Display resolution of 800 x 600 pixels or greater
  • Windows-compatible sound card
  • Windows Media Player 10.0
  • Broadband Internet connection (256 Kbps & above)

Which Browser Should I Use?

Note: To determine which version of Internet Explorer or Firefox you are using on a Windows computer, in the browser, click Help, and then click About Internet Explorer or About Mozilla Firefox. On a Macintosh, from the Firefox menu, select About Mozilla Firefox.

Use one of the following browsers:

Windows

Macintosh

Known Issue: Mac users should avoid the default Safari browser, since it causes a lot of issues when uploading files.

Note: You may get unexpected results if you use two browser windows to access the same tool at the same time. For best results, use one browser window to work in your course.

Setting Your Browser Cache

When you are using a dynamic website like elearning.ncsc.org, web browsers might show you an outdated version of a page (what is called a "cached" version of the page). See the "Setting your browser cache" page.

 

Our courses require the following software to be installed on your computer system:

  Internet Explorer 7.0

Our courses require Internet Explorer 7.0 or greater with Cookies enabled. For more information about downloading Internet Explorer 7.0 or greater, click here.

 

Our courses require Mozilla Firefox 2.0 or greater with Cookies enabled. For more information about downloading Mozilla Firefox 2.0 or greater, click here.

  Macromedia Flash Player 8.0

Our courses require the Macromedia Flash Player 9.0 or greater browser plug-in. For more information about downloading Macromedia Flash Player 9.0 or greater, click here.

  Adobe Reader

Our courses require Adobe Reader to view PDF documents. For more information about downloading, Adobe Reader, click here.

  Microsoft Windows Media Player

Our courses require Microsoft Windows Media Player for viewing the video components. For more information about downloading Microsoft Windows Media Player, click here.